• 工程项目
  • 成功案例
  • 新闻资讯
  • 技术支持
  • 联系我们
  • 技术支持

    龙8国际娱乐网页版VLAN的缔造与分别

    发布时间:2019-03-15 08:14

     
     
    我们之前曾提到关于vlan组网,但是还是有很多朋友反映:有没有更加详细、简单直接的内容这次我们用一个实例来讲解vlan的创建及组网过程,且所有的命令都有注释,我们一起来看下。在了解vlan同时,我们也来简单的了解下三层龙8国际娱乐网页版。
     
     
     
    一、为什么要选择三层龙8国际娱乐网页版

     
    1、使用二层龙8国际娱乐网页版+路由器进行VLAN间通信的问题
     
    现在,我们知道只要能提供VLAN间路由,就能够使分属不同VLAN的计算机互相通信。
     
    但是,如果使用路由器进行VLAN间路由的话,随着VLAN之间流量的不断增加,很可能导致路由器成为整个网络的瓶颈。
     
    龙8国际娱乐网页版使用被称为ASIC的专用硬件芯片处理数据帧的交换操作,在很多机型上都能实现缆线速度交换。而路由器,则基本上是基于软件处理的。
     
    就VLAN间路由而言,流量会集中到路由器和龙8国际娱乐网页版互联的汇聚链路部分,这一部分尤其特别容易成为速度瓶颈。
     
     
    2、三层龙8国际娱乐网页版
     
    为了解决上述问题,三层龙8国际娱乐网页版应运而生。三层龙8国际娱乐网页版,本质上就是“带有路由功能的(二层)龙8国际娱乐网页版”。路由属于OSI参照模型中第三层网络层的功能,因此带有第三层路由功能的龙8国际娱乐网页版才被称为“三层龙8国际娱乐网页版”。
     
    关于三层龙8国际娱乐网页版的内部结构,可以参照下面的简图。
     
     
    在一台本体内,分别设置了龙8国际娱乐网页版模块和路由器模块;而内置的路由模块与交换模块相同,使用ASIC硬件处理路由。因此,与传统的路由器相比,可以实现高速路由。
     
     
     
    二、vlan配置详细教程实例


     
    VLAN生成后龙8国际娱乐网页版是互不相通的。因此,在龙8国际娱乐网页版上设置VLAN后,如果未做其他处理,VLAN间是无法通信的。
     
    为了使大家理解,我们用个实例来讲解三层龙8国际娱乐网页版的配置,实例不同vlan间进行通信,很详细。
     
     
    配置步骤如下:
     
    1、S1三层龙8国际娱乐网页版配置:

     
    Switch>en  --进入特权模式
    Switch#conf t  --进入全局配置模式
    Switch(config)#hostname S1  --修改三层龙8国际娱乐网页版主机名为S1
    S1(config)#vtp domain test  --创建vtp域
    Domain name already set to test.
    S1(config)#vtp mode server  --设置当前龙8国际娱乐网页版在vtp的工作模式为server
    Device mode already VTP SERVER.
    S1(config)#vlan 10  --创建vlan 10
    S1(config-vlan)#vlan 20  --创建vlan 20
    S1(config-vlan)#vlan 30  --创建vlan 30
     
    S1(config-vlan)#vlan 40  --创建vlan40
    S1(config-vlan)#interface f0/1  --进入端口
    S1(config-if)#switchport mode access  --将端口模式改为access模式
    S1(config-if)#switchport mode trunk  --将端口模式改为trunk模式
     
    S1(config-if)#interface range f0/2-3  --进入端口
    S1(config-if-range)#switchport mode access   --将端口模式改为access模式
    S1(config-if-range)#switchport access vlan 40  --将端口划入vlan 40
    S1(config-if-range)#exit   --返回上一级
    S1(config)#ip routing  --启动三层龙8国际娱乐网页版的路由功能
    S1(config)#interface vlan 10  --进入vlan 10
    S1(config-if)#ip address 192.168.1.254 255.255.255.0  --给vlan 10添加ip地址
    S1(config-if)#interface vlan 20   --进入vlan 20
    S1(config-if)#ip address 192.168.2.254 255.255.255.0  --给vlan 20添加ip地址
    S1(config-if)#interface vlan 30  --进入vlan 30
    S1(config-if)#ip address 192.168.3.254 255.255.255.0  --给vlan 30添加ip地址
    S1(config-if)#interface vlan 40  --进入vlan 40
    S1(config-if)#ip address 192.168.4.254 255.255.255.0  --给vlan 40添加ip地址
    S1(config-if)#end  --返回特权模式
    S1#copy running-config startup-config  --保存配置
     
    [OK]  --保存成功
     
     
     
    2、S2龙8国际娱乐网页版配置
    Switch>en  --进入特权模式
    Switch#conf t  --进入全局配置模式
    Switch(config)#hostname S2  --修改龙8国际娱乐网页版名为S2
    S2(config)#vtp mode client  --设置当前龙8国际娱乐网页版在vtp中为客户机模式
    Device mode already VTP CLIENT.
    S2(config)#interface f0/10  --进入端口
    S2(config-if)#switchport mode trunk  --将端口设置为trunk模式
     
    S2(config-if)#interface f0/1  --进入端口
    S2(config-if)#switchport mode access  --将端口设置为access模式
    S2(config-if)#switchport access vlan 30  --将端口划入vlan30
    S2(config-if)#interface f0/2  --进入端口
    S2(config-if)#switchport mode access  --将端口设置为access模式
    S2(config-if)#switchport access vlan 20  --将端口划入vlan 20
    S2(config-if)#interface f0/3  --进入端口
    S2(config-if)#switchport mode access  --将端口设置为access模式
    S2(config-if)#switchport access vlan 10  --将端口划入vlan 10
    S2(config-if)#end  --返回特权模式
    S2#copy running-config startup-config  --保存配置
     
    [OK]  --保存成功
     
     
     
    3、S3龙8国际娱乐网页版配置
    Switch>en  --进入特权模式
    Switch#conf t  --进入全局配置模式
    Switch(config)#hostname S3  --修改龙8国际娱乐网页版名为S3
    S3(config)#vtp mode client  --设置当前龙8国际娱乐网页版在vtp中为客户模式
    Device mode already VTP CLIENT.
    S3(config)#interface range f0/10-12  --进入端口
    S3(config-if-range)#switchport mode trunk  --将端口设置为trunk模式
     
    S3(config-if-range)#interface f0/1  --进入端口
    S3(config-if)#switchport mode access  --将端口设置为access模式
    S3(config-if)#switchport access vlan 30  --将端口划入vlan 30
    S3(config-if)#interface f0/2  --进入端口
    S3(config-if)#switchport mode access   --将端口设置为access模式
    S3(config-if)#switchport access vlan 20  --将端口划入vlan20
    S3(config-if)#interface f0/3  --进入端口
    S3(config-if)#switchport mode access  --将端口设置为access模式
    S3(config-if)#switchport access vlan 10  --将端口划入vlan 20
    S3(config-if)#end  --返回特权模式
    S3#copy running-config startup-config  --保存配置
     
    [OK]  --保存成功
     
     
     
    4、S4龙8国际娱乐网页版配置
    Switch>en  --进入特权模式
    Switch#conf t  --进入全局配置模式
    Switch(config)#hostname S4  --修改龙8国际娱乐网页版名为S4
    S4(config)#vtp mode client  --设置当前龙8国际娱乐网页版在vtp中为客户模式
    S4(config)#interface f0/10  --进入端口
    S4(config-if)#switchport mode trunk  --将端口设置为trunk模式
    S4(config-if)#interface f0/1  --进入端口
    S4(config-if)#switchport mode access  --将端口设置为access模式
    S4(config-if)#switchport access vlan 30  --将端口划入vlan 30
    S4(config-if)#interface f0/2  --进入端口
    S4(config-if)#switchport mode access  --将端口设置为access模式
    S4(config-if)#switchport access vlan 20  --将端口划入vlan 20
    S4(config-if)#interface f0/3  --进入端口
    S4(config-if)#switchport mode access  --将端口设置为access模式
    S4(config-if)#switchport access vlan 10  --将端口划入vlan 10
    S4(config-if)#end  --返回特权模式
    S4#copy running-config startup-config  --保存配置
     
    [OK]  --保存成功
     
     
     
     
    三、验证
     
    测试不同vlan下的主机是否互通。
     
    1、PC11与PC33
     
     
     
    vlan10与vlan30互通
     
     
     
    2、PC13与PC21
     
     
     
    vlan10与vlan20互通。


    以上就是关于龙8国际娱乐网页版VLAN的缔造与分别的相关资讯,了解更多内容请关注信安网络科技有限公司